blob: 5d0eccd84a7d567e835bdbb614cea3bbd6622a3b [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Net::SSLeay - Perl extension for using OpenSSL"
2DESCRIPTION = "This module offers some high level convenience functions for accessing \
3web pages on SSL servers (for symmetry, same API is offered for \
4accessing http servers, too), a sslcat() function for writing your own \
5clients, and finally access to the SSL api of SSLeay/OpenSSL package \
6so you can write servers or clients for more complicated applications."
7HOMEPAGE = "http://search.cpan.org/dist/Net-SSLeay/"
8SECTION = "libs"
9
Andrew Geissler9aee5002022-03-30 16:27:02 +000010LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011LIC_FILES_CHKSUM = "file://README;beginline=274;endline=294;md5=67d67095d83e339da538a082fad5f38e"
12
13DEPENDS = "openssl zlib openssl-native"
Patrick Williams213cb262021-08-07 19:21:33 -050014RDEPENDS:${PN} += "\
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015 libssl \
16 libcrypto \
17 perl-module-carp \
18 perl-module-errno \
19 perl-module-extutils-makemaker \
20 perl-module-mime-base64 \
21 perl-module-socket \
Andrew Geisslere34f8962021-04-15 15:53:51 -050022 perl-module-autoloader \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023 zlib \
24"
25
26SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKEM/Net-SSLeay-${PV}.tar.gz \
27 file://no-exec-on-configure.patch \
28 file://run-ptest \
29 "
30SRC_URI[md5sum] = "d602bdce4e0531c6efc276e3e429ca69"
31SRC_URI[sha256sum] = "9d8188b9fb1cae3bd791979c20554925d5e94a138d00414f1a6814549927b0c8"
32
33S = "${WORKDIR}/Net-SSLeay-${PV}"
34
35inherit cpan ptest
36
37do_configure() {
38 export OPENSSL_PREFIX="${STAGING_EXECPREFIXDIR}"
39 cpan_do_configure
40}
41
42do_install_ptest() {
43 cp -r ${B}/t ${D}${PTEST_PATH}
44}
45
Patrick Williams213cb262021-08-07 19:21:33 -050046FILES:${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/Net/SSLeay/.debug/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080047
Patrick Williams213cb262021-08-07 19:21:33 -050048RDEPENDS:${PN}-ptest = " perl"