blob: c568ade9978b6ab1c694650cf0cd54c4e31066cf [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Perl interface to the libstatgrab library"
2DESCRIPTION = "Unix::Statgrab is a wrapper for libstatgrab as available from \
3<http://www.i-scream.org/libstatgrab/>. It is a reasonably portable attempt \
4to query interesting stats about your computer. It covers information on \
5the operating system, CPU, memory usage, network interfaces, hard-disks \
6etc."
7
8HOMEPAGE = "https://metacpan.org/release/Unix-Statgrab"
9SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010LICENSE = "Artistic-1.0 | GPL-1.0-or-later | LGPL-2.1-or-later"
Brad Bishope42b3e32020-01-15 22:08:42 -050011DEPENDS += "libcapture-tiny-perl-native"
12DEPENDS += "libconfig-autoconf-perl-native"
13DEPENDS += "libstatgrab"
Patrick Williams213cb262021-08-07 19:21:33 -050014RDEPENDS:${PN} += "\
Brad Bishope42b3e32020-01-15 22:08:42 -050015 libstatgrab \
16 perl-module-autoloader \
17 perl-module-carp \
18 perl-module-dynaloader \
19 perl-module-exporter \
20 perl-module-strict \
21 perl-module-vars \
22 perl-module-warnings \
23"
24
25SRC_URI = "${CPAN_MIRROR}/authors/id/R/RE/REHSACK/Unix-Statgrab-${PV}.tar.gz"
26LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
Andrew Geissler97771a32021-03-05 15:23:11 -060027 file://${COMMON_LICENSE_DIR}/GPL-1.0-or-later;md5=30c0b8a5048cc2f4be5ff15ef0d8cf61 \
28 file://${COMMON_LICENSE_DIR}/LGPL-2.1-or-later;md5=2a4f4fd2128ea2f65047ee63fbca9f68 \
Brad Bishope42b3e32020-01-15 22:08:42 -050029"
30
31SRC_URI[md5sum] = "a6bc06b3f7749f7d77a2b1bd13402821"
32SRC_URI[sha256sum] = "16a29f7acaeec081bf0e7303ba5ee24fda1d21a1104669b837745f3ea61d6afa"
33
34S = "${WORKDIR}/Unix-Statgrab-${PV}"
35
Andrew Geissler595f6302022-01-24 19:11:47 +000036export LD = "${CCLD}"
37
Brad Bishope42b3e32020-01-15 22:08:42 -050038inherit cpan pkgconfig ptest-perl
39
40BBCLASSEXTEND = "native"