blob: 80c21b2b14a51ea552d8d52f819b50b1a0ec356f [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "strictures - turn on strict and make all warnings fatal"
2DESCRIPTION = "I've been writing the equivalent of this module at the top \
3of my code for about a year now. I figured it was time to make it shorter. \
4\
5Things like the importer in \"use Moose\" don't help me because they turn \
6warnings on but don't make them fatal -- which from my point of view is \
7useless because I want an exception to tell me my code isn't warnings-clean. \
8\
9Any time I see a warning from my code, that indicates a mistake. \
10\
11Any time my code encounters a mistake, I want a crash -- not spew to STDERR \
12and then unknown (and probably undesired) subsequent behaviour. \
13\
14I also want to ensure that obvious coding mistakes, like indirect object \
15syntax (and not so obvious mistakes that cause things to accidentally compile \
16as such) get caught, but not at the cost of an XS dependency and not at the \
17cost of blowing things up on another machine. \
18\
19Therefore, \"strictures\" turns on additional checking, but only when it \
20thinks it's running in a test file in a VCS checkout -- although if this \
21causes undesired behaviour this can be overridden by setting the \
22PERL_STRICTURES_EXTRA environment variable."
23
24SECTION = "libs"
25
26HOMEPAGE = "https://metacpan.org/pod/strictures"
27
Andrew Geissler9aee5002022-03-30 16:27:02 +000028LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050029LIC_FILES_CHKSUM = "file://README;beginline=246;endline=262;md5=43be558cf4f19823cdd6af22135cf5f8"
30
31SRC_URI = "${CPAN_MIRROR}/authors/id/H/HA/HAARG/strictures-${PV}.tar.gz"
Brad Bishop15ae2502019-06-18 21:44:24 -040032SRC_URI[md5sum] = "35c14fd25320f32ff40e977feae95d0d"
33SRC_URI[sha256sum] = "09d57974a6d1b2380c802870fed471108f51170da81458e2751859f2714f8d57"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050034
35S = "${WORKDIR}/strictures-${PV}"
36
Brad Bishop15ae2502019-06-18 21:44:24 -040037inherit cpan ptest-perl
Brad Bishopd7bf8c12018-02-25 22:55:05 -050038
Patrick Williams213cb262021-08-07 19:21:33 -050039RDEPENDS:${PN} += " \
Brad Bishop15ae2502019-06-18 21:44:24 -040040 perl-module-carp \
41 perl-module-strict \
42 perl-module-test-more \
43 perl-module-warnings \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050044"
45
Patrick Williams213cb262021-08-07 19:21:33 -050046RDEPENDS:${PN}-ptest += "perl-module-perlio perl-module-perlio-scalar"
Brad Bishop15ae2502019-06-18 21:44:24 -040047
Brad Bishopd7bf8c12018-02-25 22:55:05 -050048BBCLASSEXTEND = "native"