blob: b8547cb1fe961b0e362ac3ea0eac2b807eac2040 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001# NOTE:
2# You should use perl-module-test-harness instead of this package,
3# unless you specifically need a newer version than what is provided
4# by perl in oe-core.
5
6SUMMARY = "Test::Harness - Run Perl standard test scripts with statistics"
7DESCRIPTION = "Although, for historical reasons, the Test::Harness \
8distribution takes its name from this module it now exists only to provide \
9TAP::Harness with an interface that is somewhat backwards compatible \
10with Test::Harness 2.xx. If you're writing new code consider using \
11TAP::Harness directly instead. \
12\
13Emulation is provided for runtests and execute_tests but the \
14pluggable 'Straps' interface that previous versions of Test::Harness \
15supported is not reproduced here. Straps is now available as a stand \
16alone module: Test::Harness::Straps. \
17\
18See TAP::Parser, TAP::Harness for the main documentation for this \
19distribution."
20
21SECTION = "libs"
22
23HOMEPAGE = "http://testanything.org"
24
Andrew Geissler9aee5002022-03-30 16:27:02 +000025LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Brad Bishop316dfdd2018-06-25 12:45:53 -040026LIC_FILES_CHKSUM = "file://README;beginline=29;endline=30;md5=b08db4360eec119e875dddd7cb8a5ddd"
27
28SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/Test-Harness-${PV}.tar.gz"
29SRC_URI[md5sum] = "c794906473f88d6b74194e2d56f16bd6"
30SRC_URI[sha256sum] = "0fd90d4efea82d6e262e6933759e85d27cbcfa4091b14bf4042ae20bab528e53"
31
32UPSTREAM_CHECK_REGEX = "Test\-Harness\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
33
34S = "${WORKDIR}/Test-Harness-${PV}"
35
36inherit cpan ptest-perl
37
Patrick Williams213cb262021-08-07 19:21:33 -050038RDEPENDS:${PN} += "\
Brad Bishop316dfdd2018-06-25 12:45:53 -040039 perl-module-benchmark \
40"
41
Patrick Williams213cb262021-08-07 19:21:33 -050042RPROVIDES:${PN} += "libapp-prove-perl \
Brad Bishop316dfdd2018-06-25 12:45:53 -040043 libapp-prove-state-perl \
44 libapp-prove-state-result-perl \
45 libapp-prove-state-result-test-perl \
46 libtap-base-perl \
47 libtap-formatter-base-perl \
48 libtap-formatter-color-perl \
49 libtap-formatter-console-perl \
50 libtap-formatter-console-parallelsession-perl \
51 libtap-formatter-console-session-perl \
52 libtap-formatter-file-perl \
53 libtap-formatter-file-session-perl \
54 libtap-formatter-session-perl \
55 libtap-harness-perl \
56 libtap-harness-env-perl \
57 libtap-object-perl \
58 libtap-parser-perl \
59 libtap-parser-aggregator-perl \
60 libtap-parser-grammar-perl \
61 libtap-parser-iterator-perl \
62 libtap-parser-iterator-array-perl \
63 libtap-parser-iterator-process-perl \
64 libtap-parser-iterator-stream-perl \
65 libtap-parser-iteratorfactory-perl \
66 libtap-parser-multiplexer-perl \
67 libtap-parser-result-perl \
68 libtap-parsser-result-bailout-perl \
69 libtap-parser-result-comment-perl \
70 libtap-parser-result-plan-perl \
71 libtap-parser-result-pragma-perl \
72 libtap-parser-result-test-perl \
73 libtap-parser-result-unknown-perl \
74 libtap-parser-result-version-perl \
75 libtap-parser-result-yaml-perl \
76 libtap-parser-resultfactory-perl \
77 libtap-parser-scheduler-perl \
78 libtap-parser-scheduler-job-perl \
79 libtap-parser-scheduler-spinner-perl \
80 libtap-parser-source-perl \
81 libtap-parser-sourcehandler-perl \
82 libtap-parser-sourcehandler-executable-perl \
83 libtap-parser-sourcehandler-file-perl \
84 libtap-parser-sourcehandler-handle-perl \
85 libtap-parser-sourcehandler-perl-perl \
86 libtap-parser-sourcehandler-rawtap-perl \
87 libtap-parser-yamlish-reader-perl \
88 libtap-parser-yamlish-writer-perl \
89 "
90
Patrick Williams213cb262021-08-07 19:21:33 -050091do_install:prepend() {
Brad Bishop316dfdd2018-06-25 12:45:53 -040092 # these tests are inappropriate on target
93 rm -rf ${B}/t/000-load.t
94 rm -rf ${B}/t/state.t
95 # these tests require "-T" (taint) option on command line
96 rm -rf ${B}/t/aggregator.t
97 rm -rf ${B}/t/bailout.t
98 rm -rf ${B}/t/base.t
99 rm -rf ${B}/t/callbacks.t
100 rm -rf ${B}/t/errors.t
101 rm -rf ${B}/t/nested.t
102 rm -rf ${B}/t/object.t
103 rm -rf ${B}/t/premature-bailout.t
104 rm -rf ${B}/t/results.t
105 rm -rf ${B}/t/streams.t
106 rm -rf ${B}/t/yamlish-output.t
107 rm -rf ${B}/t/compat/version.t
108}
109
Patrick Williams213cb262021-08-07 19:21:33 -0500110do_install:append() {
Brad Bishop316dfdd2018-06-25 12:45:53 -0400111 install -d ${D}/usr/local/bin
112 # do not clobber perl-misc /usr/bin/prove
113 install -m 0755 ${B}/bin/prove ${D}/usr/local/bin/
114 rm -rf ${D}${bindir}/prove
115 rm -rf ${D}${bindir}
116}
117
Patrick Williams213cb262021-08-07 19:21:33 -0500118FILES:${PN} += "/usr/local/bin/prove"
Brad Bishop316dfdd2018-06-25 12:45:53 -0400119
120BBCLASSEXTEND = "native"