blob: 7f539933d77832dd97152e44b83850bfbc42e158 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Test::Warn - Perl extension to test methods for warnings"
2DESCRIPTION = "This module provides a few convenience methods for testing \
3warning based code. \
4\
5If you are not already familiar with the Test::More manpage now would be \
6the time to go take a look. \
7"
8
9SECTION = "libs"
10HOMEPAGE= "https://metacpan.org/release/Test-Warn"
11
Andrew Geissler9aee5002022-03-30 16:27:02 +000012LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Brad Bishop26bdd442019-08-16 17:08:17 -040013LIC_FILES_CHKSUM = "file://README;beginline=73;endline=78;md5=42b423d91c92ba59c215835a2ee9b57a"
14
15CPAN_PACKAGE = "Test-Warn"
16CPAN_AUTHOR = "BIGJ"
17
18SRC_URI = "${CPAN_MIRROR}/authors/id/B/BI/${CPAN_AUTHOR}/${CPAN_PACKAGE}-${PV}.tar.gz"
19
20SRC_URI[md5sum] = "3d958f43d36db263994affde5da09b51"
21SRC_URI[sha256sum] = "ecbca346d379cef8d3c0e4ac0c8eb3b2613d737ffaaeae52271c38d7bf3c6cda"
22
23S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}"
24
25inherit cpan ptest-perl
26
27do_install_ptest() {
28 cp -r ${B}/blib ${D}${PTEST_PATH}
29 chown -R root:root ${D}${PTEST_PATH}
30}
31
Patrick Williams213cb262021-08-07 19:21:33 -050032RDEPENDS:${PN} += " \
Brad Bishop26bdd442019-08-16 17:08:17 -040033 libsub-uplevel-perl \
34 perl-module-blib \
35 perl-module-carp \
36 perl-module-test-builder \
37 perl-module-test-builder-tester \
38 perl-module-test-tester \
39"
40
Patrick Williams213cb262021-08-07 19:21:33 -050041RDEPENDS:${PN}-ptest += " \
Brad Bishop26bdd442019-08-16 17:08:17 -040042 perl-module-file-spec \
43 perl-module-test-more \
44"
45
46BBCLASSEXTEND = "native nativesdk"