blob: 96d6de6a69a3377686e4505a8421c9011ae79c1c [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Arpeggio is a recursive descent parser with memoization based on PEG grammars (aka Packrat parser)"
2HOMEPAGE = "https://pypi.org/project/Arpeggio/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=33b8d1ba459a2fa4d801acfd1d1b7ceb"
5
6SRC_URI[sha256sum] = "d6b03839019bb8a68785f9292ee6a36b1954eb84b925b84a6b8a5e1e26d3ed3d"
7
8PYPI_PACKAGE = "Arpeggio"
9inherit pypi setuptools3
10
11# setup.py of Arpeggio needs this.
12DEPENDS += "\
13 ${PYTHON_PN}-pytest-runner-native \
14 ${PYTHON_PN}-wheel-native \
15"
16
17BBCLASSEXTEND = "native nativesdk"