blob: b1d19ce6197d8fa9c50d546bbb73f92394d99aea [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "asyncio-compatible timeout context manager"
2DESCRIPTION = "\
3The context manager is useful in cases when you want to apply \
4timeout logic around block of code or in cases when asyncio.wait_for() \
5is not suitable. Also it's much faster than asyncio.wait_for() because \
6timeout doesn't create a new task."
7HOMEPAGE = "https://github.com/aio-libs/async-timeout"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=4fa41f15bb5f23b6d3560c5845eb8d57"
10
11SRC_URI[sha256sum] = "2163e1640ddb52b7a8c80d0a67a08587e5d245cc9c553a74a847056bc2976b15"
12
13PYPI_PACKAGE = "async-timeout"
Andrew Geissler9aee5002022-03-30 16:27:02 +000014inherit pypi python_setuptools_build_meta
Andrew Geissler595f6302022-01-24 19:11:47 +000015
16RDEPENDS:${PN} = "\
17 ${PYTHON_PN}-asyncio \
18"