blob: 0b2181e4fecc5129bb32337af1ea4ae42e8ed8c6 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "SDK for connecting to AWS IoT using Python."
2HOMEPAGE = "https://github.com/aws/aws-iot-device-sdk-python"
3LICENSE = "Apache-2.0 & (EPL-1.0 | EDL-1.0)"
4LICENSE:${PN}-examples = "Apache-2.0"
5LIC_FILES_CHKSUM = "\
6 file://LICENSE.txt;md5=9ac49901b833e769c7d6f21e8dbd7b30 \
7 file://AWSIoTPythonSDK/core/protocol/paho/client.py;endline=14;md5=5a3c8a1a4bb71bd934f450ecff972ad9 \
8"
9SRCREV = "6ca6c73775c953114f83240a850a0d1ab49b68ac"
10SRC_URI = "git://github.com/aws/aws-iot-device-sdk-python;branch=master;protocol=https \
11 file://0001-setup.py-Use-setuptools-instead-of-distutils.patch \
12 "
13
14S = "${WORKDIR}/git"
15
16inherit setuptools3
17
18PYPI_PACKAGE = "AWSIoTPythonSDK"
19
20do_install:append() {
21 install -d -m0755 ${D}${datadir}/${BPN}/examples
22 cp --preserve=mode,timestamps -R ${S}/samples/* ${D}${datadir}/${BPN}/examples
23 # this requires the full blown AWS Python SDK
24 rm -r ${D}${datadir}/${BPN}/examples/basicPubSub
25}
26
27PACKAGES =+ "${PN}-examples"
28
29RDEPENDS:${PN} += " \
30 ${PYTHON_PN}-crypt \
31 ${PYTHON_PN}-datetime \
32 ${PYTHON_PN}-io \
33 ${PYTHON_PN}-json \
34 ${PYTHON_PN}-logging \
35 ${PYTHON_PN}-math \
36 ${PYTHON_PN}-netclient \
37 ${PYTHON_PN}-numbers \
38 ${PYTHON_PN}-threading \
39"
40RDEPENDS:${PN}-examples += "${PN}"
41
42FILES:${PN}-examples = "${datadir}/${BPN}/examples"
43
44BBCLASSEXTEND = "native nativesdk"