blob: c179071afa76910056625c3d8bad6daffd7efc79 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "CAN BUS tools in Python 3."
2HOMEPAGE = "https://github.com/eerimoq/cantools"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d9aa4ec07de78abae21c490c9ffe61bd"
5
6SRC_URI[sha256sum] = "e603a7e1e40f5b4963c4c64cf4b013264afa009e232a878c73d31c29942e4466"
7
8PYPI_PACKAGE = "cantools"
9
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += "\
13 ${PYTHON_PN}-can \
14 ${PYTHON_PN}-bitstruct \
15 ${PYTHON_PN}-core \
16 ${PYTHON_PN}-textparser \
17 ${PYTHON_PN}-typing-extensions \
18 ${PYTHON_PN}-diskcache \
19"
20
21CLEANBROKEN = "1"