blob: cafc32ad1094b9851839a4c1c52767c3a235ec08 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001DESCRIPTION = "An implementation of RFC 7049 - Concise Binary Object Representation (CBOR)."
2DEPENDS +="${PYTHON_PN}-setuptools-scm-native"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7SRC_URI[sha256sum] = "e283e70b55a049ff364cc5e648fde587e4d9b0e87e4b2664c69e639135e6b3b8"
8
Andrew Geissler9aee5002022-03-30 16:27:02 +00009inherit pypi python_setuptools_build_meta ptest
Andrew Geisslereff27472021-10-29 15:35:00 -050010
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17 ${PYTHON_PN}-unixadmin \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
24
25RDEPENDS:${PN} += " \
26 ${PYTHON_PN}-datetime \
27"
28
29BBCLASSEXTEND = "native nativesdk"