blob: 4f6a3aba998c14a3cfb1adb3d303b3e23f821ccd [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A python package implementing the crc32c algorithmin hardware and software"
2HOMEPAGE = "https://github.com/ICRAR/crc32c"
3
4LICENSE = "BSD-2-Clause & BSD-3-Clause & CRC32C-ADLER & LGPL-2.0-or-later"
5LIC_FILES_CHKSUM = " \
6 file://LICENSE;md5=4fbd65380cdd255951079008b364516c \
7 file://LICENSE.google-crc32c;md5=e9ed01b5e5ac9eae23fc2bb33701220c \
8 file://LICENSE.slice-by-8;md5=6b3bc7709d6b2db6646ec2467310ff6b \
9 file://crc32c_adler.c;startline=9;endline=24;md5=c60e6e55d0e5d95effa6fad27db0711a \
10"
11
12SRC_URI[sha256sum] = "3d058e7a5e37e4985d1a7ad4cb702bca56b490daa658d4851377d13ead8b435e"
13
14inherit pypi setuptools3
15
16do_compile:prepend() {
17 if ! grep 'platform =' setup.cfg; then
18 printf "[build_ext]\nplatform = ${TARGET_ARCH}" >> setup.cfg
19 fi
20}
21
22RDEPENDS:${PN} += "python3-core"