blob: c4d4df383a9b73ad639bf531e90e5e26a38da531 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API."
2DESCRIPTION = "lxml is a Pythonic, mature binding for the libxml2 and \
3libxslt libraries. It provides safe and convenient access to these \
4libraries using the ElementTree API. It extends the ElementTree API \
5significantly to offer support for XPath, RelaxNG, XML Schema, XSLT, \
6C14N and much more."
7HOMEPAGE = "https://lxml.de/"
8SECTION = "devel/python"
9LICENSE = "BSD-3-Clause & GPL-2.0-only & MIT & PSF-2.0"
10LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \
11 file://doc/licenses/elementtree.txt;md5=eb34d036a6e3d56314ee49a6852ac891 \
12 file://doc/licenses/BSD.txt;md5=700a1fc17f4797d4f2d34970c8ee694b \
13 file://doc/licenses/GPL.txt;md5=94d55d512a9ba36caa9b7df079bae19f \
14 file://src/lxml/isoschematron/resources/rng/iso-schematron.rng;beginline=2;endline=7;md5=fc85684a8dd5fa272c086bceb0d99e10 \
15 file://src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl;beginline=2;endline=24;md5=cc86b7b2bbc678e13f58ea403eb9929b \
16 file://src/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl;beginline=2;endline=7;md5=5b03236d293dc3784205542b409d2f53 \
17 "
18
19DEPENDS += "libxml2 libxslt"
20
21SRC_URI[sha256sum] = "f63f62fc60e6228a4ca9abae28228f35e1bd3ce675013d1dfb828688d50c6e23"
22
23SRC_URI += "${PYPI_SRC_URI}"
24inherit pkgconfig pypi setuptools3
25
26# {standard input}: Assembler messages:
27# {standard input}:1488805: Error: branch out of range
28DEBUG_OPTIMIZATION:remove:mips = " -Og"
29DEBUG_OPTIMIZATION:append:mips = " -O"
30BUILD_OPTIMIZATION:remove:mips = " -Og"
31BUILD_OPTIMIZATION:append:mips = " -O"
32
33DEBUG_OPTIMIZATION:remove:mipsel = " -Og"
34DEBUG_OPTIMIZATION:append:mipsel = " -O"
35BUILD_OPTIMIZATION:remove:mipsel = " -Og"
36BUILD_OPTIMIZATION:append:mipsel = " -O"
37
38BBCLASSEXTEND = "native nativesdk"
39
40RDEPENDS:${PN} += "libxml2 libxslt ${PYTHON_PN}-compression"
41
42CLEANBROKEN = "1"