blob: ef5b00627259831328757e49bfd88c5e7eb907d1 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "python bindings for the lz4 compression library by Yann Collet"
2
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=6231efa4dd4811e62407314d90a57573"
5
6DEPENDS += " \
7 lz4 \
8 ${PYTHON_PN}-setuptools-scm-native \
9 ${PYTHON_PN}-pkgconfig-native \
10"
11
12SRC_URI += "file://run-ptest"
13
14SRC_URI[sha256sum] = "57c5dfd3b7dae833b0d2b2c1aafd7f9d0dfcab40683d183d010c67c9fd1beca3"
15
16inherit pkgconfig pypi python_setuptools_build_meta ptest
17
18RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest ${PYTHON_PN}-multiprocessing ${PYTHON_PN}-psutil"
19
20do_install_ptest() {
21 cp -rf ${S}/tests/ ${D}${PTEST_PATH}/
22 # The stream API is experimental and not enabled yet, so don't ship the test suite
23 rm -rf ${D}${PTEST_PATH}/tests/stream
24}
25
26BBCLASSEXTEND = "native nativesdk"