blob: dc5f1738880b3f91d11b976db0a69ee230390a8f [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Simplified object serialization in python"
2DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converting complex datatypes, such as objects, to and from native Python datatypes."
3AUTHOR = "Marius Kriegerowski <mk@quakesaver.net>"
4HOMEPAGE = "https://github.com/marshmallow-code/marshmallow"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "\
7 file://LICENSE;md5=5bccd400dedfa74364481e56aacc0b4a \
8 file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb"
9
10SRC_URI = "git://github.com/marshmallow-code/marshmallow.git;protocol=https;branch=dev"
11
12SRCREV = "41afdefd93afd1b95f48f45fd284ff8add3e91b7"
13
14S = "${WORKDIR}/git"
15
16inherit setuptools3
17
Andrew Geissler9aee5002022-03-30 16:27:02 +000018PIP_INSTALL_PACKAGE = "marshmallow"
19
Andrew Geissler595f6302022-01-24 19:11:47 +000020RDEPENDS:${PN} += "python3-core"