blob: f555144f45a0de7d4318c39e316efb68c37fd1b7 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Physical quantities module"
2DESCRIPTION = "Physical quantities Python module"
3HOMEPAGE = "https://github.com/hgrecco/pint"
4SECTION = "devel/python"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
8
9PYPI_PACKAGE := "Pint"
10
Andrew Geissler9aee5002022-03-30 16:27:02 +000011inherit pypi ptest python_setuptools_build_meta
Andrew Geissler595f6302022-01-24 19:11:47 +000012
13SRC_URI[sha256sum] = "8c4bce884c269051feb7abc69dbfd18403c0c764abc83da132e8a7222f8ba801"
14
15DEPENDS += "python3-setuptools-scm-native"
16
17BBCLASSEXTEND = "native nativesdk"
18
19SRC_URI += " \
20 file://run-ptest \
21"
22
23RDEPENDS:${PN} += " \
24 ${PYTHON_PN}-setuptools \
25 ${PYTHON_PN}-packaging \
26"
27
28RDEPENDS:${PN}-ptest += " \
29 ${PYTHON_PN}-pytest \
30"
31
32do_install_ptest() {
33 install -d ${D}${PTEST_PATH}/testsuite
34 cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
35}