blob: 6e5346197965ecd545f116d186b7649c9baf36f6 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Python binding to the Networking and Cryptography (NaCl) library"
2DESCRIPTION = "Python binding to the Networking and Cryptography (NaCl) library"
3HOMEPAGE = "https://github.com/pyca/pynacl"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f"
6
7SRC_URI[sha256sum] = "8ac7448f09ab85811607bdd21ec2464495ac8b7c66d146bf545b0f08fb9220ba"
8
9PYPI_PACKAGE = "PyNaCl"
10
Andrew Geissler9aee5002022-03-30 16:27:02 +000011inherit pypi python_setuptools_build_meta
Andrew Geissler595f6302022-01-24 19:11:47 +000012
13DEPENDS += "\
Andrew Geissler595f6302022-01-24 19:11:47 +000014 ${PYTHON_PN}-cffi-native \
15 libsodium \
16"
17
18RDEPENDS:${PN} = "\
19 ${PYTHON_PN}-six \
20 ${PYTHON_PN}-cffi \
21 libsodium \
22"
23
24do_compile:prepend() {
25 export SODIUM_INSTALL=system
26}
27
28do_install:prepend() {
29 export SODIUM_INSTALL=system
30}