blob: 4c4c959eba49ad9547c3a57e6ec5b260bf367c77 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A libudev binding"
2
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "LGPL-2.1-or-later"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00004LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
5
6SRC_URI[sha256sum] = "32ae3585b320a51bc283e0a04000fd8a25599edb44541e2f5034f6afee5d15cc"
7
8inherit pypi setuptools3
9
10do_configure:prepend() {
11 sed -i "/import pyudev/d" ${S}/setup.py
12 sed -i "s/str(pyudev.__version__)/'${PV}'/g" ${S}/setup.py
13}
14
15RDEPENDS:${PN} = "\
16 ${PYTHON_PN}-ctypes \
17 ${PYTHON_PN}-misc \
18 ${PYTHON_PN}-six \
19 ${PYTHON_PN}-threading \
20 ${PYTHON_PN}-fcntl \
21 libudev \
22"
23
24BBCLASSEXTEND = "native nativesdk"