blob: 63453517ecd57b5792e60ba860b13b5b2aa966cd [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A generator framework based on a common modern IDL"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=eee61e10a40b0e3045ee5965bcd9a8b5"
4
5SRC_URI[sha256sum] = "87ce8ce7123ae57d91ac903c6c330a99273e7f4665a0ab88e6a17f9c98143a68"
6
7inherit pypi python_setuptools_build_meta
8
9DEPS = "\
10 python3-jinja2 \
11 python3-click \
12 python3-pyyaml \
13 python3-pytest \
14 python3-six \
15 python3-path \
16 python3-antlr4-runtime \
17 python3-watchdog \
18 python3-markupsafe \
19 python3-setuptools \
20"
21DEPENDS += "${DEPS}"
22RDEPENDS:${PN} += "${DEPS}"
23
24BBCLASSEXTEND = "nativesdk native"