blob: be0bafd33f7f1d818ef29d1201538d87f20f6fb8 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "SMPP library for python"
2SECTION = "devel/python"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-3.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00004LIC_FILES_CHKSUM = "file://README.md;md5=8b4e2ac8cf248f7b991784f88b630852"
5
6PYPI_PACKAGE = "smpplib"
7SRC_URI[sha256sum] = "c0b01947b47e404f42ccb59e906b6e4eb507963c971d59b44350db0f29c76166"
8
9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN} += " \
16 ${PYTHON_PN}-logging \
17 ${PYTHON_PN}-six \
18"
19
20RDEPENDS:${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22 ${PYTHON_PN}-unittest \
23 ${PYTHON_PN}-profile \
24 ${PYTHON_PN}-mock \
25"
26
27do_install_ptest() {
28 install -d ${D}${PTEST_PATH}/tests
29 cp -rf ${S}/smpplib/tests/* ${D}${PTEST_PATH}/tests/
30}