blob: e9fce61452b63c87c1b2211ca1dd4ff6119b1ca6 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Run-time type checker for Python"
2HOMEPAGE = "https://pypi.org/project/typeguard/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
5
6SRC_URI[sha256sum] = "00edaa8da3a133674796cf5ea87d9f4b4c367d77476e185e80251cc13dfbb8c4"
7
Andrew Geissler9aee5002022-03-30 16:27:02 +00008inherit pypi python_setuptools_build_meta ptest
Andrew Geissler595f6302022-01-24 19:11:47 +00009
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15 ${PYTHON_PN}-pytest \
16 ${PYTHON_PN}-typing-extensions \
17 ${PYTHON_PN}-unixadmin \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
24
25DEPENDS += "\
26 python3-distutils-extra-native \
27 python3-setuptools-scm-native \
28"
29
30BBCLASSEXTEND = "native nativesdk"