blob: c26ae1fe98e98f39dd857db7eb267800c1555425 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "GUI tool for storage configuration using blivet library"
2HOMEPAGE = "https://github.com/rhinstaller/blivet-gui"
3LICENSE = "GPL-2.0-or-later"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8S = "${WORKDIR}/git"
9B = "${S}"
10
11SRCREV = "42512ee48494cee71febf04078d9774f0146a085"
12SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=master;protocol=https \
13 file://0001-Use-setuptools-instead-of-distutils-in-setup.py.patch \
14 "
15
16inherit features_check
17REQUIRED_DISTRO_FEATURES = "x11 systemd"
18
19inherit setuptools3_legacy python3native
20
21PIP_INSTALL_PACKAGE = "blivet_gui"
22
23RDEPENDS:${PN} = "python3-pygobject python3 \
24 python3-blivet gtk+3 \
25 python3-pid libreport \
26"
27
28FILES:${PN} += " \
29 ${datadir}/* \
30 "