blob: 857a4e86fd7ae528bcc6aa43fed4ab228e97de37 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Linux control group abstraction library"
2HOMEPAGE = "http://libcg.sourceforge.net/"
3DESCRIPTION = "libcgroup is a library that abstracts the control group file system \
4in Linux. Control groups allow you to limit, account and isolate resource usage \
5(CPU, memory, disk I/O, etc.) of groups of processes."
6SECTION = "libs"
7LICENSE = "LGPL-2.1-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
9
10inherit autotools pkgconfig
11
12DEPENDS = "bison-native flex-native"
13
14SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz"
15
16SRC_URI[sha256sum] = "2dd9c566a90a053e7a5f47607e225648ba7aa9bb7763514dd4778e2ed530fe90"
17UPSTREAM_CHECK_URI = "https://github.com/libcgroup/libcgroup/releases/"
18
19DEPENDS:append:libc-musl = " fts "
20EXTRA_OEMAKE:append:libc-musl = " LIBS=-lfts"
21
22PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}"
23PACKAGECONFIG[pam] = "--enable-pam-module-dir=${base_libdir}/security --enable-pam=yes,--enable-pam=no,libpam"
24
25PACKAGES =+ "cgroups-pam-plugin"
26FILES:cgroups-pam-plugin = "${base_libdir}/security/pam_cgroup.so*"
27FILES:${PN}-dev += "${base_libdir}/security/*.la"
28FILES:${PN}-staticdev += "${base_libdir}/security/pam_cgroup.a"
29
30do_install:append() {
31 # Until we ship the test suite, this library isn't useful
32 rm -f ${D}${libdir}/libcgroupfortesting.*
33}