blob: e361b53bfd226581a53fda04f25a3ffde14d2eae [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "XML C Parser Library and Toolkit"
2DESCRIPTION = "The XML Parser Library allows for manipulation of XML files. Libxml2 exports Push and Pull type parser interfaces for both XML and HTML. It can do DTD validation at parse time, on a parsed document instance or with an arbitrary DTD. Libxml2 includes complete XPath, XPointer and Xinclude implementations. It also has a SAX like interface, which is designed to be compatible with Expat."
3HOMEPAGE = "https://gitlab.gnome.org/GNOME/libxml2"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml2"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
8 file://hash.c;beginline=6;endline=15;md5=e77f77b12cb69e203d8b4090a0eee879 \
9 file://list.c;beginline=4;endline=13;md5=b9c25b021ccaf287e50060602d20f3a7 \
10 file://trio.c;beginline=5;endline=14;md5=cd4f61e27f88c1d43df112966b1cd28f"
11
12DEPENDS = "zlib virtual/libiconv"
13
14inherit gnomebase
15
16SRC_URI += "http://www.w3.org/XML/Test/xmlts20080827.tar.gz;subdir=${BP};name=testtar \
17 file://libxml-64bit.patch \
18 file://runtest.patch \
19 file://run-ptest \
20 file://python-sitepackages-dir.patch \
21 file://0001-Make-ptest-run-the-python-tests-if-python-is-enabled.patch \
22 file://fix-execution-of-ptests.patch \
23 file://remove-fuzz-from-ptests.patch \
24 file://libxml-m4-use-pkgconfig.patch \
25 "
26# will be in v2.9.14
27#
28SRC_URI += "file://CVE-2022-23308-fix-regression.patch"
29
30SRC_URI[archive.sha256sum] = "276130602d12fe484ecc03447ee5e759d0465558fbc9d6bd144e3745306ebf0e"
31SRC_URI[testtar.sha256sum] = "96151685cec997e1f9f3387e3626d61e6284d4d6e66e0e440c209286c03e9cc7"
32
33BINCONFIG = "${bindir}/xml2-config"
34
35PACKAGECONFIG ??= "python \
36 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
37"
38PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python3"
39PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
40
41inherit autotools pkgconfig binconfig-disabled ptest
42
43inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3targetconfig', '', d)}
44
45RDEPENDS:${PN}-ptest += "bash make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
46
47RDEPENDS:${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}"
48
49RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-gconv-ebcdic-us \
50 glibc-gconv-ibm1141 \
51 glibc-gconv-iso8859-5 \
52 glibc-gconv-euc-jp \
53 locale-base-en-us \
54 "
55
56export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
57
58# WARNING: zlib is required for RPM use
59EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
60EXTRA_OECONF:class-native = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
61EXTRA_OECONF:class-nativesdk = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
62EXTRA_OECONF:linuxstdbase = "--with-debug --with-legacy --with-docbook --with-c14n --without-lzma --with-zlib"
63
64python populate_packages:prepend () {
65 # autonamer would call this libxml2-2, but we don't want that
66 if d.getVar('DEBIAN_NAMES'):
67 d.setVar('PKG:libxml2', '${MLPREFIX}libxml2')
68}
69
70PACKAGE_BEFORE_PN += "${PN}-utils"
71PACKAGES += "${PN}-python"
72
73FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
74FILES:${PN}-dev += "${libdir}/xml2Conf.sh"
75FILES:${PN}-utils = "${bindir}/*"
76FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
77
78do_configure:prepend () {
79 # executables take longer to package: these should not be executable
80 find ${S}/xmlconf/ -type f -exec chmod -x {} \+
81}
82
83do_compile_ptest() {
84 oe_runmake check-am
85}
86
87do_install_ptest () {
88 cp -r ${S}/xmlconf ${D}${PTEST_PATH}
89 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
90 sed -i -e 's|^\(PYTHON = \).*|\1${USRBINPATH}/${PYTHON_PN}|' \
91 ${D}${PTEST_PATH}/python/tests/Makefile
92 grep -lrZ '#!/usr/bin/python' ${D}${PTEST_PATH}/python |
93 xargs -0 sed -i -e 's|/usr/bin/python|${USRBINPATH}/${PYTHON_PN}|'
94 fi
95 #Remove build host references from various Makefiles
96 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
97 sed -i \
98 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
99 -e 's|${DEBUG_PREFIX_MAP}||g' \
100 -e 's:${HOSTTOOLS_DIR}/::g' \
101 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
102 -e 's:${RECIPE_SYSROOT}::g' \
103 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
104 -e '/^RELDATE/d' \
105 {} +
106}
107
108do_install:append:class-native () {
109 # Docs are not needed in the native case
110 rm ${D}${datadir}/gtk-doc -rf
111}
112
113BBCLASSEXTEND = "native nativesdk"