blob: 99a9ca1027c16b4883410834a2f400f0ff907e77 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Perl-cross build system"
2HOMEPAGE = "https://github.com/arsv/perl-cross"
3DESCRIPTION = "perl-cross provides configure script, top-level Makefile and some auxiliary files for perl, \
4with the primary emphasis on cross-compiling the source."
5SECTION = "devel"
6LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
7# README.md is taken from https://github.com/arsv/perl-cross/blob/master/README.md
8# but is not provided inside the release tarballs
9LIC_FILES_CHKSUM = "file://${WORKDIR}/README.md;md5=252fcce2026b765fee1ad74d2fb07a3b"
10
11inherit allarch
12
13SRC_URI = "https://github.com/arsv/perl-cross/releases/download/${PV}/perl-cross-${PV}.tar.gz;name=perl-cross \
14 file://README.md \
15 file://0001-perl-cross-add-LDFLAGS-when-linking-libperl.patch \
16 file://determinism.patch \
17 file://0001-Makefile-check-the-file-if-patched-or-not.patch \
18 "
19UPSTREAM_CHECK_URI = "https://github.com/arsv/perl-cross/releases/"
20
21SRC_URI[perl-cross.sha256sum] = "77f13ca84a63025053852331b72d4046c1f90ded98bd45ccedea738621907335"
22
23S = "${WORKDIR}/perl-cross-${PV}"
24
25do_configure () {
26}
27
28do_compile () {
29}
30
31do_install:class-native() {
32 mkdir -p ${D}/${datadir}/perl-cross/
33 cp -rf ${S}/* ${D}/${datadir}/perl-cross/
34 rm -rf ${D}/${datadir}/perl-cross/patches/
35}
36
37BBCLASSEXTEND = "native"
38