blob: f53bdc974ad4fe1c959a6c8a7cdcfab13e19dedc [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Universal encoding detector for Python 2 and 3"
2HOMEPAGE = "https://pypi.org/project/chardet/"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343"
5
6SRC_URI[sha256sum] = "0d6f53a15db4120f2b08c94f11e7d93d2c911ee118b6b30a04ec3ee8310179fa"
7
8# setup.py of chardet needs this.
9DEPENDS += "${PYTHON_PN}-pytest-runner-native"
10
11inherit pypi setuptools3
12
13PACKAGES =+ "${PN}-cli"
14FILES:${PN}-cli += " \
15 ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \
16"
17
18RDEPENDS:${PN}-cli = "${PN} "
19
20RDEPENDS:${PN}:class-target += " \
21 ${PYTHON_PN}-logging \
22"
23
24BBCLASSEXTEND = "native nativesdk"