blob: f4f9e1bde6480e0185e287e95a03ed95d0bd6dbe [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Library and tool for installing Python wheels"
2DESCRIPTION = "A low-level library for installing a Python package from a wheel distribution."
3HOMEPAGE = "https://installer.readthedocs.io/"
4BUGTRACKER = "https://github.com/pypa/installer/issues"
5
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=5038641aec7a77451e31da828ebfae00"
8
9SRC_URI += "file://interpreter.patch"
10
11SRC_URI[sha256sum] = "f970995ec2bb815e2fdaf7977b26b2091e1e386f0f42eafd5ac811953dc5d445"
12
13inherit pypi python_flit_core
14
15DEPENDS:remove:class-native = "python3-installer-native"
16DEPENDS:append:class-native = " unzip-native"
17
18do_install:class-native () {
19 python_pep517_do_bootstrap_install
20}
21
22BBCLASSEXTEND = "native nativesdk"