blob: ee3e578b2c8af9e6314c4b1ed0e1f2a4bce3421f [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "The PyPA recommended tool for installing Python packages"
2HOMEPAGE = "https://pypi.org/project/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=63ec52baf95163b597008bb46db68030"
6
Andrew Geissler9aee5002022-03-30 16:27:02 +00007inherit pypi python_setuptools_build_meta
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008
9SRC_URI += "file://0001-change-shebang-to-python3.patch"
10SRC_URI += "file://no_shebang_mangling.patch"
11SRC_URI += "file://reproducible.patch"
12
13SRC_URI[sha256sum] = "f29d589df8c8ab99c060e68ad294c4a9ed896624f6368c5349d70aa581b333d0"
14
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000015do_install:append() {
Andrew Geissler9aee5002022-03-30 16:27:02 +000016 rm -f ${D}/${bindir}/pip
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000017}
18
19RDEPENDS:${PN} = "\
20 python3-compile \
21 python3-io \
22 python3-html \
23 python3-json \
24 python3-multiprocessing \
25 python3-netserver \
26 python3-setuptools \
27 python3-unixadmin \
28 python3-xmlrpc \
29 python3-pickle \
30"
31
32BBCLASSEXTEND = "native nativesdk"
Andrew Geissler9aee5002022-03-30 16:27:02 +000033
34# This used to use the bootstrap install which didn't compile. Until we bump the
35# tmpdir version we can't compile the native otherwise the sysroot unpack fails
36INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"