blob: 53b7367903ee9109a55bad54b18fb153a8990a64 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Parser of the C language, written in pure Python"
2HOMEPAGE = "https://github.com/eliben/pycparser"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=2c28cdeabcb88f5843d934381b4b4fea"
5
6SRC_URI[sha256sum] = "e644fdec12f7872f86c58ff790da456218b10f863970249516d60a5eaca77206"
7
8inherit pypi setuptools3
9
10BBCLASSEXTEND = "native nativesdk"
11
12RDEPENDS:${PN}:class-target += "\
13 ${PYTHON_PN}-netclient \
14 ${PYTHON_PN}-ply \
15 ${PYTHON_PN}-pprint \
16 "
17
18RSUGGESTS:${PN}:class-target += "\
19 cpp \
20 cpp-symlinks \
21 "