blob: db0e809ef5405bbf2f447e28d102070fc0ba6d34 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Simple Python wrapper around the OpenSSL library"
2HOMEPAGE = "https://pyopenssl.org/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6DEPENDS += "openssl ${PYTHON_PN}-cryptography"
7
8SRC_URI[sha256sum] = "660b1b1425aac4a1bea1d94168a85d99f0b3144c869dd4390d27629d0087f1bf"
9
10PYPI_PACKAGE = "pyOpenSSL"
11inherit pypi setuptools3
12
13PACKAGES =+ "${PN}-tests"
14FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
15
16RDEPENDS:${PN}:class-target = " \
17 ${PYTHON_PN}-cryptography \
18 ${PYTHON_PN}-six \
19 ${PYTHON_PN}-threading \
20"
21RDEPENDS:${PN}-tests = "${PN}"
22
23BBCLASSEXTEND = "native nativesdk"