blob: 9c3896918f60b7ddb86e0eb800aa0f5aebeff6e8 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Python parsing module"
2DESCRIPTION = "The pyparsing module is an alternative approach to creating \
3and executing simple grammars, vs. the traditional lex/yacc approach, or \
4the use of regular expressions. The pyparsing module provides a library of \
5classes that client code uses to construct the grammar directly in Python \
6code."
7HOMEPAGE = "https://github.com/pyparsing/pyparsing/"
8BUGTRACKER = "https://github.com/pyparsing/pyparsing/issues"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=657a566233888513e1f07ba13e2f47f1"
12
13SRC_URI[sha256sum] = "18ee9022775d270c55187733956460083db60b37d0d0fb357445f3094eed3eea"
14
15UPSTREAM_CHECK_REGEX = "pyparsing-(?P<pver>.*)\.tar"
16
17inherit pypi setuptools3
18
19RDEPENDS:${PN} += " \
20 ${PYTHON_PN}-datetime \
21 ${PYTHON_PN}-debugger \
Andrew Geissler9aee5002022-03-30 16:27:02 +000022 ${PYTHON_PN}-html \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000023 ${PYTHON_PN}-json \
24 ${PYTHON_PN}-netclient \
25 ${PYTHON_PN}-pprint \
26 ${PYTHON_PN}-stringold \
27 ${PYTHON_PN}-threading \
28"
29
30BBCLASSEXTEND = "native nativesdk"