blob: f7a2c1bb9578f60bd36474471c81b015726c5294 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Invoke py.test as distutils command with dependency resolution"
2HOMEPAGE = "https://pypi.org/project/pytest-runner/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
5
6SRC_URI[sha256sum] = "b4d85362ed29b4c348678de797df438f0f0509497ddb8c647096c02a6d87b685"
7
8inherit pypi python_setuptools_build_meta
9
10DEPENDS += " \
11 ${PYTHON_PN}-setuptools-scm-native"
12
13RDEPENDS:${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-debugger ${PYTHON_PN}-json \
14 ${PYTHON_PN}-io ${PYTHON_PN}-distutils"
15
16BBCLASSEXTEND = "native nativesdk"