blob: 060a6ff6cf50c6e21c1b0059acce3fc26b573c9f [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "unittest subTest() support and subtests fixture."
2DESCRIPTION = "Adds support for TestCase.subTest.\
3New subtests fixture, providing similar functionality for pure pytest tests."
4HOMEPAGE = "https://github.com/pytest-dev/pytest-subtests"
5BUGTRACKER = "https://github.com/pytest-dev/pytest-subtests/issues"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=242b4e17fa287dcf7aef372f6bc3dcb1"
9
10SRC_URI[sha256sum] = "95c44c77e3fbede9848bb88ca90b384815fcba8090ef9a9f55659ab163b1681c"
11
12inherit pypi setuptools3
13
14DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
15
16RDEPENDS:${PN} += " \
17 ${PYTHON_PN}-pytest \
18"
19
20BBCLASSEXTEND = "native nativesdk"