blob: f2810e18d3150d1c5176cd127024355a173ff745 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "https://pypi.org/project/setuptools"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=7a7126e068206290f3fe9f8d6c713ea6"
6
Andrew Geissler9aee5002022-03-30 16:27:02 +00007inherit pypi python_setuptools_build_meta
Andrew Geissler595f6302022-01-24 19:11:47 +00008
9SRC_URI:append:class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch"
10
11SRC_URI += "\
12 file://0001-change-shebang-to-python3.patch \
13 file://0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch \
14"
15
16SRC_URI[sha256sum] = "d144f85102f999444d06f9c0e8c737fd0194f10f2f7e5fdb77573f6e2fa4fad0"
17
18DEPENDS += "${PYTHON_PN}"
19
20RDEPENDS:${PN} = "\
21 ${PYTHON_PN}-2to3 \
22 ${PYTHON_PN}-compile \
23 ${PYTHON_PN}-compression \
24 ${PYTHON_PN}-ctypes \
25 ${PYTHON_PN}-email \
26 ${PYTHON_PN}-html \
27 ${PYTHON_PN}-json \
28 ${PYTHON_PN}-netserver \
29 ${PYTHON_PN}-numbers \
30 ${PYTHON_PN}-pickle \
31 ${PYTHON_PN}-pkg-resources \
32 ${PYTHON_PN}-pkgutil \
33 ${PYTHON_PN}-plistlib \
34 ${PYTHON_PN}-shell \
35 ${PYTHON_PN}-stringold \
36 ${PYTHON_PN}-threading \
37 ${PYTHON_PN}-unittest \
38 ${PYTHON_PN}-xml \
39"
40
Andrew Geissler595f6302022-01-24 19:11:47 +000041BBCLASSEXTEND = "native nativesdk"
42
43# The pkg-resources module can be used by itself, without the package downloader
44# and easy_install. Ship it in a separate package so that it can be used by
45# minimal distributions.
46PACKAGES =+ "${PYTHON_PN}-pkg-resources "
47FILES:${PYTHON_PN}-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*"
48RDEPENDS:${PYTHON_PN}-pkg-resources = "\
49 ${PYTHON_PN}-compression \
50 ${PYTHON_PN}-email \
51 ${PYTHON_PN}-plistlib \
52 ${PYTHON_PN}-pprint \
53"
Andrew Geissler9aee5002022-03-30 16:27:02 +000054
55# This used to use the bootstrap install which didn't compile. Until we bump the
56# tmpdir version we can't compile the native otherwise the sysroot unpack fails
57INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"