blob: 97ec2619cb9da979195f6f93239f546440eb91f4 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Python documentation generator"
2HOMEPAGE = "http://sphinx-doc.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-2-Clause & MIT & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=de4349dda741c550eb8b20f6b92f38d7"
6
7PYPI_PACKAGE = "Sphinx"
8
9SRC_URI[sha256sum] = "6caad9786055cb1fa22b4a365c1775816b876f91966481765d7d50e9f0dd35cc"
10
11inherit setuptools3 pypi
12
13
14do_install:append () {
15 # The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?)
16 rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex*
17}
18
19RDEPENDS:${PN} = "\
20 python3-packaging python3-docutils python3-requests \
21 python3-imagesize python3-alabaster python3-jinja2 \
22 python3-babel python3-pygments python3-snowballstemmer \
23 python3-sphinxcontrib-applehelp python3-sphinxcontrib-devhelp \
24 python3-sphinxcontrib-jsmath python3-sphinxcontrib-htmlhelp \
25 python3-sphinxcontrib-serializinghtml python3-sphinxcontrib-qthelp \
26 "
27
28BBCLASSEXTEND = "native nativesdk"