blob: 95ae4a54a4064708c395daa72054116abe1855eb [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
2HOMEPAGE = "https://github.com/shazow/urllib3"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c2823cb995439c984fd62a973d79815c"
5
6SRC_URI[sha256sum] = "aabaf16477806a5e1dd19aa41f8c2b7950dd3c746362d7e3223dbe6de6ac448e"
7
8inherit pypi setuptools3
9
10RDEPENDS:${PN} += "\
11 ${PYTHON_PN}-certifi \
12 ${PYTHON_PN}-cryptography \
13 ${PYTHON_PN}-email \
14 ${PYTHON_PN}-idna \
15 ${PYTHON_PN}-netclient \
16 ${PYTHON_PN}-pyopenssl \
17 ${PYTHON_PN}-threading \
18"
19
20CVE_PRODUCT = "urllib3"
21
22BBCLASSEXTEND = "native nativesdk"