blob: 4ab9edbce4cbc2ebca0c6f525e03485b046fef94 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Tool for creating HTML, PDF, EPUB, man pages"
2DESCRIPTION = "AsciiDoc is a text document format for writing short documents, \
3articles, books and UNIX man pages."
4
5HOMEPAGE = "http://asciidoc.org/"
6
7LICENSE = "GPL-2.0-only"
8LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=aaee33adce0fc7cc40fee23f82f7f101 \
9 file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10 "
11
12SRC_URI = "git://github.com/asciidoc/asciidoc-py;protocol=https;branch=main"
13SRCREV = "c724bbf95b1840b04bb298a61a72b6a5ea94c2ef"
14
15DEPENDS = "libxml2-native libxslt-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native"
16
17S = "${WORKDIR}/git"
18
19# Tell xmllint where to find the DocBook XML catalogue, because right now it
20# opens /etc/xml/catalog on the host. Depends on auto-catalogs.patch
21export SGML_CATALOG_FILES="file://${STAGING_ETCDIR_NATIVE}/xml/catalog"
22
23inherit setuptools3
24CLEANBROKEN = "1"
25
26BBCLASSEXTEND = "native nativesdk"
27
28UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))$"