blob: 3b4188284113ed5ece5efe724ccd4d0d37c16e5d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Tools for managing kernel packet filtering capabilities"
2DESCRIPTION = "iptables is the userspace command line program used to configure and control network packet \
3filtering code in Linux."
4HOMEPAGE = "http://www.netfilter.org/"
5BUGTRACKER = "http://bugzilla.netfilter.org/"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-2.0-or-later"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://iptables/iptables.c;beginline=13;endline=25;md5=c5cffd09974558cf27d0f763df2a12dc \
9"
10
11SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2 \
12 file://0001-configure-Add-option-to-enable-disable-libnfnetlink.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +000013 file://0001-Makefile.am-do-not-install-etc-ethertypes.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050014 file://0002-configure.ac-only-check-conntrack-when-libnfnetlink-enabled.patch \
15 file://iptables.service \
16 file://iptables.rules \
17 file://ip6tables.service \
18 file://ip6tables.rules \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060019 "
Andrew Geisslerd1e89492021-02-12 15:35:20 -060020SRC_URI[sha256sum] = "c109c96bb04998cd44156622d36f8e04b140701ec60531a10668cfdff5e8d8f0"
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
Patrick Williams213cb262021-08-07 19:21:33 -050022SYSTEMD_SERVICE:${PN} = "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050023 iptables.service \
24 ${@bb.utils.contains('PACKAGECONFIG', 'ipv6', 'ip6tables.service', '', d)} \
25"
26
27inherit autotools pkgconfig systemd
28
29EXTRA_OECONF = "--with-kernel=${STAGING_INCDIR}"
30
31PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
32PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
33
34# libnfnetlink recipe is in meta-networking layer
35PACKAGECONFIG[libnfnetlink] = "--enable-libnfnetlink,--disable-libnfnetlink,libnfnetlink libnetfilter-conntrack"
36
37# libnftnl recipe is in meta-networking layer(previously known as libnftables)
38PACKAGECONFIG[libnftnl] = "--enable-nftables,--disable-nftables,libnftnl"
39
Patrick Williams213cb262021-08-07 19:21:33 -050040do_configure:prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050041 # Remove some libtool m4 files
42 # Keep ax_check_linker_flags.m4 which belongs to autoconf-archive.
43 rm -f libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4
44}
45
46IPTABLES_RULES_DIR ?= "${sysconfdir}/${BPN}"
47
Patrick Williams213cb262021-08-07 19:21:33 -050048do_install:append() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050049 install -d ${D}${IPTABLES_RULES_DIR}
50 install -m 0644 ${WORKDIR}/iptables.rules ${D}${IPTABLES_RULES_DIR}
51
52 install -d ${D}${systemd_system_unitdir}
53 install -m 0644 ${WORKDIR}/iptables.service ${D}${systemd_system_unitdir}
54
55 sed -i \
56 -e 's,@SBINDIR@,${sbindir},g' \
57 -e 's,@RULESDIR@,${IPTABLES_RULES_DIR},g' \
58 ${D}${systemd_system_unitdir}/iptables.service
59
60 if ${@bb.utils.contains('PACKAGECONFIG', 'ipv6', 'true', 'false', d)} ; then
61 install -m 0644 ${WORKDIR}/ip6tables.rules ${D}${IPTABLES_RULES_DIR}
62 install -m 0644 ${WORKDIR}/ip6tables.service ${D}${systemd_system_unitdir}
63
64 sed -i \
65 -e 's,@SBINDIR@,${sbindir},g' \
66 -e 's,@RULESDIR@,${IPTABLES_RULES_DIR},g' \
67 ${D}${systemd_system_unitdir}/ip6tables.service
68 fi
Andrew Geissler9aee5002022-03-30 16:27:02 +000069
70 # if libnftnl is included, make the iptables symlink point to the nft-based binary by default
71 if ${@bb.utils.contains('PACKAGECONFIG', 'libnftnl', 'true', 'false', d)} ; then
72 ln -sf ${sbindir}/xtables-nft-multi ${D}${sbindir}/iptables
73 fi
Andrew Geissler82c905d2020-04-13 13:39:40 -050074}
75
Andrew Geisslerd25ed322020-06-27 00:28:28 -050076PACKAGES =+ "${PN}-modules ${PN}-apply"
Andrew Geissler82c905d2020-04-13 13:39:40 -050077PACKAGES_DYNAMIC += "^${PN}-module-.*"
78
Patrick Williams213cb262021-08-07 19:21:33 -050079python populate_packages:prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050080 modules = do_split_packages(d, '${libdir}/xtables', r'lib(.*)\.so$', '${PN}-module-%s', '${PN} module %s', extra_depends='')
81 if modules:
82 metapkg = d.getVar('PN') + '-modules'
Patrick Williams213cb262021-08-07 19:21:33 -050083 d.appendVar('RDEPENDS:' + metapkg, ' ' + ' '.join(modules))
Andrew Geissler82c905d2020-04-13 13:39:40 -050084}
85
Patrick Williams213cb262021-08-07 19:21:33 -050086RDEPENDS:${PN} = "${PN}-module-xt-standard"
87RRECOMMENDS:${PN} = " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050088 ${PN}-modules \
89 kernel-module-x-tables \
90 kernel-module-ip-tables \
91 kernel-module-iptable-filter \
92 kernel-module-iptable-nat \
93 kernel-module-nf-defrag-ipv4 \
94 kernel-module-nf-conntrack \
95 kernel-module-nf-conntrack-ipv4 \
96 kernel-module-nf-nat \
97 kernel-module-ipt-masquerade \
98 ${@bb.utils.contains('PACKAGECONFIG', 'ipv6', '\
99 kernel-module-ip6table-filter \
100 kernel-module-ip6-tables \
101 ', '', d)} \
102"
103
Patrick Williams213cb262021-08-07 19:21:33 -0500104FILES:${PN} += "${datadir}/xtables"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500105
Patrick Williams213cb262021-08-07 19:21:33 -0500106FILES:${PN}-apply = "${sbindir}/ip*-apply"
107RDEPENDS:${PN}-apply = "${PN} bash"
Andrew Geisslerd25ed322020-06-27 00:28:28 -0500108
Andrew Geissler82c905d2020-04-13 13:39:40 -0500109# Include the symlinks as well in respective packages
Patrick Williams213cb262021-08-07 19:21:33 -0500110FILES:${PN}-module-xt-conntrack += "${libdir}/xtables/libxt_state.so"
111FILES:${PN}-module-xt-ct += "${libdir}/xtables/libxt_NOTRACK.so"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500112
Patrick Williams213cb262021-08-07 19:21:33 -0500113ALLOW_EMPTY:${PN}-modules = "1"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500114
Patrick Williams213cb262021-08-07 19:21:33 -0500115INSANE_SKIP:${PN}-module-xt-conntrack = "dev-so"
116INSANE_SKIP:${PN}-module-xt-ct = "dev-so"