blob: 2af406212fe4d0b7d74cc49d53e4d1189a5e5262 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "OpenGL / OpenGL ES Reference Compiler"
2DESCRIPTION = "Glslang is the official reference compiler front end for the \
3OpenGL ES and OpenGL shading languages. It implements a strict interpretation \
4of the specifications for these languages. It is open and free for anyone to use, \
5either from a command line or programmatically."
6SECTION = "graphics"
7HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
8LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception"
9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2a2b5acd7bc4844964cfda45fe807dc3"
10
11SRCREV = "2742e959347ae2fac58acd0d022c92a0ff1f24bf"
12SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https;branch=master \
13 file://0001-generate-glslang-pkg-config.patch"
14PE = "1"
15UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
16S = "${WORKDIR}/git"
17
18inherit cmake python3native
19
20EXTRA_OECMAKE = " \
21 -DCMAKE_BUILD_TYPE=Release \
22 -DBUILD_SHARED_LIBS=ON \
23 -DENABLE_PCH=OFF \
24 -DENABLE_CTEST=OFF \
25 -DBUILD_EXTERNAL=OFF \
26"
27
28SOLIBSDEV = "glslang.so"
29# all the other libraries are unversioned, so pack it on PN
30FILES:${PN} += "${libdir}/*.so"
31
32BBCLASSEXTEND = "native nativesdk"