blob: 58ce26a3d51607313fc8b17dc57e35c1a99cb484 [file] [log] [blame]
Andrew Geissler90fd73c2021-03-05 15:25:55 -06001SUMMARY = "Demo application to showcase 3D graphics using kms and gbm"
2DESCRIPTION = "kmscube is a little demonstration program for how to drive bare metal graphics \
3without a compositor like X11, wayland or similar, using DRM/KMS (kernel mode \
4setting), GBM (graphics buffer manager) and EGL for rendering content using \
5OpenGL or OpenGL ES."
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006HOMEPAGE = "https://cgit.freedesktop.org/mesa/kmscube/"
7LICENSE = "MIT"
8SECTION = "graphics"
Andrew Geissler595f6302022-01-24 19:11:47 +00009DEPENDS = "virtual/libgles3 virtual/libgles2 virtual/egl libdrm"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010
11LIC_FILES_CHKSUM = "file://kmscube.c;beginline=1;endline=23;md5=8b309d4ee67b7315ff7381270dd631fb"
12
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060013SRCREV = "9f63f359fab1b5d8e862508e4e51c9dfe339ccb0"
Andrew Geissler4b740dc2020-05-05 08:54:39 -050014SRC_URI = "git://gitlab.freedesktop.org/mesa/kmscube;branch=master;protocol=https"
Andrew Geissler595f6302022-01-24 19:11:47 +000015SRC_URI += "file://0001-texturator-Use-correct-GL-extension-header.patch"
Brad Bishop316dfdd2018-06-25 12:45:53 -040016UPSTREAM_CHECK_COMMITS = "1"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
18S = "${WORKDIR}/git"
19
Brad Bishop6dbb3162019-11-25 09:41:34 -050020inherit meson pkgconfig features_check
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021
22REQUIRED_DISTRO_FEATURES = "opengl"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000023DEPENDS = "virtual/libgbm"
Brad Bishop19323692019-04-05 15:28:33 -040024
25PACKAGECONFIG ??= ""
26PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0 gstreamer1.0-plugins-base"
Andrew Geissler9aee5002022-03-30 16:27:02 +000027
28CFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_NO_X11=1', d)}"
29