blob: 08ff5a0bb55cfd9fb29c3fbf5b4c7f44608b5689 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001require gstreamer1.0-plugins-common.inc
2
3DESCRIPTION = "'Good' GStreamer plugins"
4HOMEPAGE = "https://gstreamer.freedesktop.org/"
5BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/issues"
6
7SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \
8 file://0001-qt-include-ext-qt-gstqtgl.h-instead-of-gst-gl-gstglf.patch \
9 "
10
11SRC_URI[sha256sum] = "3c66876f821d507bcdbebffb08b4f31a322727d6753f65a0f02c905ecb7084aa"
12
13S = "${WORKDIR}/gst-plugins-good-${PV}"
14
15LICENSE = "LGPL-2.1-or-later"
16LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
17 file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
18
19DEPENDS += "gstreamer1.0-plugins-base libcap zlib"
20RPROVIDES:${PN}-pulseaudio += "${PN}-pulse"
21RPROVIDES:${PN}-soup += "${PN}-souphttpsrc"
22
23PACKAGECONFIG ??= " \
24 ${GSTREAMER_ORC} \
25 ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \
26 ${@bb.utils.contains('TUNE_FEATURES', 'm64', 'asm', '', d)} \
27 bz2 cairo flac gdk-pixbuf gudev jpeg lame libpng mpg123 soup speex taglib v4l2 \
28"
29
30X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
31X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled"
32X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled"
33
34QT5WAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
35
36PACKAGECONFIG[asm] = "-Dasm=enabled,-Dasm=disabled,nasm-native"
37PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
38PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo"
39PACKAGECONFIG[dv1394] = "-Ddv1394=enabled,-Ddv1394=disabled,libiec61883 libavc1394 libraw1394"
40PACKAGECONFIG[flac] = "-Dflac=enabled,-Dflac=disabled,flac"
41PACKAGECONFIG[gdk-pixbuf] = "-Dgdk-pixbuf=enabled,-Dgdk-pixbuf=disabled,gdk-pixbuf"
42PACKAGECONFIG[gtk] = "-Dgtk3=enabled,-Dgtk3=disabled,gtk+3"
43PACKAGECONFIG[gudev] = "-Dv4l2-gudev=enabled,-Dv4l2-gudev=disabled,libgudev"
44PACKAGECONFIG[jack] = "-Djack=enabled,-Djack=disabled,jack"
45PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,jpeg"
46PACKAGECONFIG[lame] = "-Dlame=enabled,-Dlame=disabled,lame"
47PACKAGECONFIG[libpng] = "-Dpng=enabled,-Dpng=disabled,libpng"
48PACKAGECONFIG[libv4l2] = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils"
49PACKAGECONFIG[mpg123] = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
50PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio"
51PACKAGECONFIG[qt5] = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QT5WAYLANDDEPENDS}"
52PACKAGECONFIG[soup] = "-Dsoup=enabled,-Dsoup=disabled,libsoup-2.4"
53PACKAGECONFIG[speex] = "-Dspeex=enabled,-Dspeex=disabled,speex"
54PACKAGECONFIG[rpi] = "-Drpicamsrc=enabled,-Drpicamsrc=disabled,userland"
55PACKAGECONFIG[taglib] = "-Dtaglib=enabled,-Dtaglib=disabled,taglib"
56PACKAGECONFIG[v4l2] = "-Dv4l2=enabled -Dv4l2-probe=true,-Dv4l2=disabled -Dv4l2-probe=false"
57PACKAGECONFIG[vpx] = "-Dvpx=enabled,-Dvpx=disabled,libvpx"
58PACKAGECONFIG[wavpack] = "-Dwavpack=enabled,-Dwavpack=disabled,wavpack"
59PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
60
61EXTRA_OEMESON += " \
62 -Ddoc=disabled \
63 -Daalib=disabled \
64 -Ddirectsound=disabled \
65 -Ddv=disabled \
66 -Dlibcaca=disabled \
67 -Doss=enabled \
68 -Doss4=disabled \
69 -Dosxaudio=disabled \
70 -Dosxvideo=disabled \
71 -Dshout2=disabled \
72 -Dtwolame=disabled \
73 -Dwaveform=disabled \
74"
75
76FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"