blob: 58baf3f32f7172b93b1f9c26c46690c082c71b10 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "iCal and scheduling (RFC 2445, 2446, 2447) library"
2DESCRIPTION = "An Open Source implementation of the iCalendar protocols \
3and protocol data units. The iCalendar specification describes how \
4calendar clients can communicate with calendar servers so users can store \
5their calendar data and arrange meetings with other users. "
6HOMEPAGE = "https://github.com/libical/libical"
7BUGTRACKER = "https://github.com/libical/libical/issues"
8LICENSE = "LGPL-2.1-only | MPL-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=1910a2a76ddf6a9ba369182494170d87 \
10 file://LICENSE.LGPL21.txt;md5=933adb561f159e7c3da079536f0ed871 \
11 file://LICENSE.MPL2.txt;md5=f75d2927d3c1ed2414ef72048f5ad640 \
12 "
13SECTION = "libs"
14
Andrew Geissler9aee5002022-03-30 16:27:02 +000015SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz \
16 file://0001-cmake-Do-not-export-CC-into-gir-compiler.patch \
17 "
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000018SRC_URI[sha256sum] = "4284b780356f1dc6a01f16083e7b836e63d3815e27ed0eaaad684712357ccc8f"
19UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases"
20
21inherit cmake pkgconfig gobject-introspection vala
22
23DEPENDS += "libical-native"
24
25PACKAGECONFIG ??= "icu glib"
26PACKAGECONFIG[bdb] = ",-DCMAKE_DISABLE_FIND_PACKAGE_BDB=True,db"
27PACKAGECONFIG[glib] = "-DICAL_GLIB=True,-DICAL_GLIB=False,glib-2.0-native libxml2-native glib-2.0 libxml2"
28# ICU is used for RSCALE (RFC7529) support
29PACKAGECONFIG[icu] = ",-DCMAKE_DISABLE_FIND_PACKAGE_ICU=True,icu"
30
31# No need to use perl-native, the host perl is sufficient.
32EXTRA_OECMAKE += "-DPERL_EXECUTABLE=${HOSTTOOLS_DIR}/perl"
33# Disable the test suite as we can't install it
34EXTRA_OECMAKE += "-DLIBICAL_BUILD_TESTING=false"
35# doc build fails with linker error (??) for libical-glib so disable it
36EXTRA_OECMAKE += "-DICAL_BUILD_DOCS=false"
37# gobject-introspection
38EXTRA_OECMAKE:append:class-target = " -DGObjectIntrospection_COMPILER=${STAGING_BINDIR}/g-ir-compiler-wrapper"
39EXTRA_OECMAKE:append:class-target = " -DGObjectIntrospection_SCANNER=${STAGING_BINDIR}/g-ir-scanner-wrapper"
40EXTRA_OECMAKE += "-DVAPIGEN=${STAGING_BINDIR_NATIVE}/vapigen"
41EXTRA_OECMAKE += "${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DGOBJECT_INTROSPECTION=ON -DICAL_GLIB_VAPI=ON', '-DGOBJECT_INTROSPECTION=OFF', d)}"
42
43# Tell the cross-libical where the tool it needs to build is
44EXTRA_OECMAKE:append:class-target = " -DIMPORT_ICAL_GLIB_SRC_GENERATOR=${STAGING_LIBDIR_NATIVE}/cmake/LibIcal/IcalGlibSrcGenerator.cmake"
45
46do_install:append () {
47 # Remove build host references (https://github.com/libical/libical/issues/532)
48 sed -i \
49 -e 's,${STAGING_LIBDIR},${libdir},g' \
50 -e 's,${STAGING_INCDIR},${includedir},g' \
51 ${D}${libdir}/cmake/LibIcal/LibIcal*.cmake \
52 ${D}${libdir}/cmake/LibIcal/Ical*.cmake
53}
54
55BBCLASSEXTEND = "native"