blob: 51cfb2e28111121063cfc08c8137e30c9c9be798 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "GNOME XSLT library"
2DESCRIPTION = "libxslt is the XSLT C parser and toolkit developed for the Gnome project. \
3XSLT itself is a an XML language to define transformation for XML. Libxslt is based on \
4libxml2 the XML C library developed for the GNOME project. It also implements most of \
5the EXSLT set of processor-portable extensions functions and some of Saxon's evaluate \
6and expressions extensions."
7HOMEPAGE = "http://xmlsoft.org/XSLT/"
8BUGTRACKER = "https://bugzilla.gnome.org/"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
12
13SECTION = "libs"
14DEPENDS = "libxml2"
15
16SRC_URI = "https://download.gnome.org/sources/libxslt/1.1/libxslt-${PV}.tar.xz"
17
18SRC_URI[sha256sum] = "8247f33e9a872c6ac859aa45018bc4c4d00b97e2feac9eebc10c93ce1f34dd79"
19
20UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
21
22S = "${WORKDIR}/libxslt-${PV}"
23
24BINCONFIG = "${bindir}/xslt-config"
25
26inherit autotools pkgconfig binconfig-disabled lib_package multilib_header
27
28do_configure:prepend () {
29 # We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header.
30 # This can be removed when upgrading to 1.1.34.
31 sed -i -e 's/ansidecl.h//' ${S}/configure.ac
32
33 # The timestamps in the 1.1.28 tarball are messed up causing this file to
34 # appear out of date. Touch it so that we don't try to regenerate it.
35 touch ${S}/doc/xsltproc.1
36}
37
38EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto --with-html-subdir=${BPN}"
39# older versions of this recipe had ${PN}-utils
40RPROVIDES:${PN}-bin += "${PN}-utils"
41RCONFLICTS:${PN}-bin += "${PN}-utils"
42RREPLACES:${PN}-bin += "${PN}-utils"
43
44# This is only needed until libxml can load the relocated catalog itself
45do_install:append:class-native () {
46 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog
47}
48
49do_install:append () {
50 oe_multilib_header libxslt/xsltconfig.h
51}
52
53FILES:${PN} += "${libdir}/libxslt-plugins"
54FILES:${PN}-dev += "${libdir}/xsltConf.sh"
55
56BBCLASSEXTEND = "native nativesdk"