blob: 58ce08084de7cae1d71033174318c5155499f073 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "HTTP/2 C Library and tools"
2HOMEPAGE = "https://nghttp2.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec"
6
7UPSTREAM_CHECK_URI = "https://github.com/nghttp2/nghttp2/releases"
8
9SRC_URI = "\
10 https://github.com/nghttp2/nghttp2/releases/download/v${PV}/nghttp2-${PV}.tar.xz \
11 file://0001-fetch-ocsp-response-use-python3.patch \
12"
13SRC_URI[sha256sum] = "68271951324554c34501b85190f22f2221056db69f493afc3bbac8e7be21e7cc"
14
15inherit cmake manpages python3native
16PACKAGECONFIG[manpages] = ""
17
18# examples are never installed, and don't need to be built in the
19# first place
20EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF"
21
22PACKAGES =+ "lib${BPN} ${PN}-client ${PN}-proxy ${PN}-server"
23
24RDEPENDS:${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) ${PN}-server (>= ${PV})"
25RDEPENDS:${PN}:class-native = ""
26RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell"
27
28ALLOW_EMPTY:${PN} = "1"
29FILES:${PN} = ""
30FILES:lib${BPN} = "${libdir}/*${SOLIBS}"
31FILES:${PN}-client = "${bindir}/h2load ${bindir}/nghttp"
32FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
33FILES:${PN}-server = "${bindir}/nghttpd"
34
35BBCLASSEXTEND = "native nativesdk"