blob: b6eaaa8af4ce20146625df750ee66c777d531bda [file] [log] [blame]
Patrick Venture9afb6712018-09-17 17:14:46 -07001HOMEPAGE = "http://github.com/openbmc/google-ipmi-sys"
2SUMMARY = "Google Sys OEM commands"
3DESCRIPTION = "Google sys OEM commands"
4
5inherit autotools pkgconfig
6inherit obmc-phosphor-license
7inherit systemd
8inherit obmc-phosphor-ipmiprovider-symlink
9
10DEPENDS += "autoconf-archive-native"
11DEPENDS += "sdbusplus"
12DEPENDS += "phosphor-logging"
13
14# We depend on this to be built first so we can build our providers.
15DEPENDS += "phosphor-ipmi-host"
16
17RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
18
19S = "${WORKDIR}/git"
20SRC_URI = "git://github.com/openbmc/google-ipmi-sys"
21SRCREV = "f9a19b80bea5987292e61b8b2aedcc3baedcaf8f"
22
23FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
24FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
25FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
26FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
27
28HOSTIPMI_PROVIDER_LIBRARY += "libsyscmds.so"
29
30SYSTEMD_PACKAGES = "${PN}"
31SYSTEMD_SERVICE_${PN} = "gbmc-psu-hardreset.target"
32
33do_install_append() {
34 install -d ${D}${systemd_system_unitdir}
35 install -m 0644 ${S}/gbmc-psu-hardreset.target ${D}${systemd_system_unitdir}
36}