blob: 73aa0ee9694f11ba102f597507a5d1ea3da0f7d3 [file] [log] [blame]
Andrew Geisslerd1e89492021-02-12 15:35:20 -06001SUMMARY = "A collection of tools, libraries and tests for shader compilation"
2DESCRIPTION = "The Shaderc library provides an API for compiling GLSL/HLSL \
3source code to SPIRV modules. It has been shipping in the Android NDK since version r12b."
4SECTION = "graphics"
5HOMEPAGE = "https://github.com/google/shaderc"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9SRCREV = "0dbd899941a43ffd55df527d65128b3b66e75c9c"
10SRC_URI = "git://github.com/google/shaderc.git;protocol=https;branch=main \
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060011 file://0001-cmake-disable-building-external-dependencies.patch \
12 file://0002-libshaderc_util-fix-glslang-header-file-location.patch \
13 file://0003-cmake-add-option-to-skip-build-the-examples.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060014 "
15UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>\d+(\.\d+)+)$"
16S = "${WORKDIR}/git"
17
18inherit cmake python3native
19
20DEPENDS = "spirv-headers spirv-tools glslang"
21
22EXTRA_OECMAKE = " \
23 -DCMAKE_BUILD_TYPE=Release \
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060024 -DBUILD_EXTERNAL=OFF \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060025 -DSHADERC_SKIP_TESTS=ON \
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060026 -DSHADERC_SKIP_EXAMPLES=ON \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060027"
28
29BBCLASSEXTEND = "native nativesdk"