blob: bd2155233246ae1f7f8ea78bbb723934ac5b4e3f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A complete, cross-platform solution to record, convert and stream audio and video."
2DESCRIPTION = "FFmpeg is the leading multimedia framework, able to decode, encode, transcode, \
3 mux, demux, stream, filter and play pretty much anything that humans and machines \
4 have created. It supports the most obscure ancient formats up to the cutting edge."
5HOMEPAGE = "https://www.ffmpeg.org/"
6SECTION = "libs"
7
8LICENSE = "BSD & GPLv2+ & LGPLv2.1+ & MIT"
9LICENSE_${PN} = "GPLv2+"
10LICENSE_libavcodec = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
11LICENSE_libavdevice = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
12LICENSE_libavfilter = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
13LICENSE_libavformat = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
14LICENSE_libavresample = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
15LICENSE_libavutil = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
16LICENSE_libpostproc = "GPLv2+"
17LICENSE_libswresample = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
18LICENSE_libswscale = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
19LICENSE_FLAGS = "commercial"
20
21LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
22 file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \
23 file://COPYING.LGPLv2.1;md5=bd7a443320af8c812e4c18d1b79df004 \
24 file://COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02"
25
26SRC_URI = "https://www.ffmpeg.org/releases/${BP}.tar.xz \
27 file://mips64_cpu_detection.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060028 file://0001-lavf-srt-fix-build-fail-when-used-the-libsrt-1.4.1.patch \
Andrew Geissler09209ee2020-12-13 08:44:15 -060029 file://0001-libavutil-include-assembly-with-full-path-from-sourc.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060030 file://CVE-2020-35964.patch \
31 file://CVE-2020-35965.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050032 "
Andrew Geisslerb7d28612020-07-24 16:15:54 -050033SRC_URI[sha256sum] = "ad009240d46e307b4e03a213a0f49c11b650e445b1f8be0dda2a9212b34d2ffb"
Andrew Geissler82c905d2020-04-13 13:39:40 -050034
35# Build fails when thumb is enabled: https://bugzilla.yoctoproject.org/show_bug.cgi?id=7717
36ARM_INSTRUCTION_SET_armv4 = "arm"
37ARM_INSTRUCTION_SET_armv5 = "arm"
38ARM_INSTRUCTION_SET_armv6 = "arm"
39
40# Should be API compatible with libav (which was a fork of ffmpeg)
41# libpostproc was previously packaged from a separate recipe
42PROVIDES = "libav libpostproc"
43
44DEPENDS = "nasm-native"
45
46inherit autotools pkgconfig
47
48PACKAGECONFIG ??= "avdevice avfilter avcodec avformat swresample swscale postproc avresample \
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060049 alsa bzlib gpl lzma pic pthreads shared theora x264 zlib \
50 ${@bb.utils.contains('AVAILTUNES', 'mips32r2', 'mips32r2', '', d)} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050051 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xv xcb', '', d)}"
52
53# libraries to build in addition to avutil
54PACKAGECONFIG[avdevice] = "--enable-avdevice,--disable-avdevice"
55PACKAGECONFIG[avfilter] = "--enable-avfilter,--disable-avfilter"
56PACKAGECONFIG[avcodec] = "--enable-avcodec,--disable-avcodec"
57PACKAGECONFIG[avformat] = "--enable-avformat,--disable-avformat"
58PACKAGECONFIG[swresample] = "--enable-swresample,--disable-swresample"
59PACKAGECONFIG[swscale] = "--enable-swscale,--disable-swscale"
60PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc"
61PACKAGECONFIG[avresample] = "--enable-avresample,--disable-avresample"
62
63# features to support
64PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
Andrew Geissler475cb722020-07-10 16:00:51 -050065PACKAGECONFIG[altivec] = "--enable-altivec,--disable-altivec,"
Andrew Geissler82c905d2020-04-13 13:39:40 -050066PACKAGECONFIG[bzlib] = "--enable-bzlib,--disable-bzlib,bzip2"
67PACKAGECONFIG[fdk-aac] = "--enable-libfdk-aac --enable-nonfree,--disable-libfdk-aac,fdk-aac"
68PACKAGECONFIG[gpl] = "--enable-gpl,--disable-gpl"
69PACKAGECONFIG[gsm] = "--enable-libgsm,--disable-libgsm,libgsm"
70PACKAGECONFIG[jack] = "--enable-indev=jack,--disable-indev=jack,jack"
71PACKAGECONFIG[libvorbis] = "--enable-libvorbis,--disable-libvorbis,libvorbis"
72PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz"
73PACKAGECONFIG[mfx] = "--enable-libmfx,--disable-libmfx,intel-mediasdk"
74PACKAGECONFIG[mp3lame] = "--enable-libmp3lame,--disable-libmp3lame,lame"
75PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
76PACKAGECONFIG[sdl2] = "--enable-sdl2,--disable-sdl2,virtual/libsdl2"
77PACKAGECONFIG[speex] = "--enable-libspeex,--disable-libspeex,speex"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060078PACKAGECONFIG[srt] = "--enable-libsrt,--disable-libsrt,srt"
Andrew Geissler82c905d2020-04-13 13:39:40 -050079PACKAGECONFIG[theora] = "--enable-libtheora,--disable-libtheora,libtheora libogg"
80PACKAGECONFIG[vaapi] = "--enable-vaapi,--disable-vaapi,libva"
81PACKAGECONFIG[vdpau] = "--enable-vdpau,--disable-vdpau,libvdpau"
82PACKAGECONFIG[vpx] = "--enable-libvpx,--disable-libvpx,libvpx"
83PACKAGECONFIG[x264] = "--enable-libx264,--disable-libx264,x264"
84PACKAGECONFIG[x265] = "--enable-libx265,--disable-libx265,x265"
85PACKAGECONFIG[xcb] = "--enable-libxcb,--disable-libxcb,libxcb"
86PACKAGECONFIG[xv] = "--enable-outdev=xv,--disable-outdev=xv,libxv"
87PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib"
88
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060089# other configuration options
90PACKAGECONFIG[mips32r2] = ",--disable-mipsdsp --disable-mipsdspr2"
91PACKAGECONFIG[pic] = "--enable-pic"
92PACKAGECONFIG[pthreads] = "--enable-pthreads,--disable-pthreads"
93PACKAGECONFIG[shared] = "--enable-shared"
94PACKAGECONFIG[strip] = ",--disable-stripping"
95
Andrew Geissler82c905d2020-04-13 13:39:40 -050096# Check codecs that require --enable-nonfree
97USE_NONFREE = "${@bb.utils.contains_any('PACKAGECONFIG', [ 'openssl' ], 'yes', '', d)}"
98
99def cpu(d):
100 for arg in (d.getVar('TUNE_CCARGS') or '').split():
101 if arg.startswith('-mcpu='):
102 return arg[6:]
103 return 'generic'
104
105EXTRA_OECONF = " \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500106 ${@bb.utils.contains('USE_NONFREE', 'yes', '--enable-nonfree', '', d)} \
107 \
108 --cross-prefix=${TARGET_PREFIX} \
109 \
110 --ld="${CCLD}" \
111 --cc="${CC}" \
112 --cxx="${CXX}" \
113 --arch=${TARGET_ARCH} \
114 --target-os="linux" \
115 --enable-cross-compile \
116 --extra-cflags="${CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
117 --extra-ldflags="${LDFLAGS}" \
118 --sysroot="${STAGING_DIR_TARGET}" \
119 ${EXTRA_FFCONF} \
120 --libdir=${libdir} \
121 --shlibdir=${libdir} \
122 --datadir=${datadir}/ffmpeg \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500123 --cpu=${@cpu(d)} \
124 --pkg-config=pkg-config \
125"
126
127EXTRA_OECONF_append_linux-gnux32 = " --disable-asm"
128# gold crashes on x86, another solution is to --disable-asm but thats more hacky
129# ld.gold: internal error in relocate_section, at ../../gold/i386.cc:3684
130
131LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
132
133EXTRA_OEMAKE = "V=1"
134
135do_configure() {
136 ${S}/configure ${EXTRA_OECONF}
137}
138
Andrew Geissler09209ee2020-12-13 08:44:15 -0600139# patch out build host paths for reproducibility
140do_compile_prepend_class-target() {
141 sed -i -e "s,${WORKDIR},,g" ${B}/config.h
142}
143
Andrew Geissler82c905d2020-04-13 13:39:40 -0500144PACKAGES =+ "libavcodec \
145 libavdevice \
146 libavfilter \
147 libavformat \
148 libavresample \
149 libavutil \
150 libpostproc \
151 libswresample \
152 libswscale"
153
154FILES_libavcodec = "${libdir}/libavcodec${SOLIBS}"
155FILES_libavdevice = "${libdir}/libavdevice${SOLIBS}"
156FILES_libavfilter = "${libdir}/libavfilter${SOLIBS}"
157FILES_libavformat = "${libdir}/libavformat${SOLIBS}"
158FILES_libavresample = "${libdir}/libavresample${SOLIBS}"
159FILES_libavutil = "${libdir}/libavutil${SOLIBS}"
160FILES_libpostproc = "${libdir}/libpostproc${SOLIBS}"
161FILES_libswresample = "${libdir}/libswresample${SOLIBS}"
162FILES_libswscale = "${libdir}/libswscale${SOLIBS}"
163
164# ffmpeg disables PIC on some platforms (e.g. x86-32)
165INSANE_SKIP_${MLPREFIX}libavcodec = "textrel"
166INSANE_SKIP_${MLPREFIX}libavdevice = "textrel"
167INSANE_SKIP_${MLPREFIX}libavfilter = "textrel"
168INSANE_SKIP_${MLPREFIX}libavformat = "textrel"
169INSANE_SKIP_${MLPREFIX}libavutil = "textrel"
170INSANE_SKIP_${MLPREFIX}libavresample = "textrel"
171INSANE_SKIP_${MLPREFIX}libswscale = "textrel"
172INSANE_SKIP_${MLPREFIX}libswresample = "textrel"
173INSANE_SKIP_${MLPREFIX}libpostproc = "textrel"