blob: 03ce088fc8973f0411800c266a1111ed78becf54 [file] [log] [blame]
Lancelot Kao4357d532021-02-22 15:20:35 -06001SUMMARY = "Phosphor OpenBMC Kudo Firmware Upgrade Command"
2DESCRIPTION = "Phosphor OpenBMC Kudo Firmware Upgrade Comman Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
11DEPENDS += "systemd"
12DEPENDS += "phosphor-ipmi-flash"
13RDEPENDS_${PN} += "libsystemd"
14RDEPENDS_${PN} += "bash"
15
16
XP Chen9b906962021-05-06 15:23:19 -050017SRC_URI = " \
Lancelot Kao4357d532021-02-22 15:20:35 -060018 file://kudo-fw.sh \
19 file://kudo-fw-ver.service \
20 file://kudo-fw-ver.sh \
XP Chen9b906962021-05-06 15:23:19 -050021 file://kudo-lib.sh \
Lancelot Kao4357d532021-02-22 15:20:35 -060022 "
23
24SYSTEMD_PACKAGES = "${PN}"
XP Chen9b906962021-05-06 15:23:19 -050025SYSTEMD_SERVICE_${PN} = " \
Lancelot Kao4357d532021-02-22 15:20:35 -060026 kudo-fw-ver.service \
27 "
28
29do_install () {
30 install -d ${D}/${sbindir}
31 install -m 0755 ${WORKDIR}/kudo-fw.sh ${D}/${sbindir}/kudo-fw.sh
32 install -m 0755 ${WORKDIR}/kudo-fw-ver.sh ${D}/${sbindir}/kudo-fw-ver.sh
XP Chen9b906962021-05-06 15:23:19 -050033 install -m 0755 ${WORKDIR}/kudo-lib.sh ${D}/${sbindir}/kudo-lib.sh
Lancelot Kao4357d532021-02-22 15:20:35 -060034 install -d ${D}${systemd_system_unitdir}
35 install -m 0644 ${WORKDIR}/kudo-fw-ver.service ${D}${systemd_system_unitdir}
36}