blob: e726c9ac66d7aa5763ee0942b17f8a43ecca7d0f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A simple, fast and secure HTTP server"
2HOMEPAGE = "http://www.nazgul.ch/dev_nostromo.html"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://src/nhttpd/main.c;beginline=2;endline=14;md5=0bb3711a867b9704d3bfabcf5529b64e"
5
6SRC_URI = "http://www.nazgul.ch/dev/${BPN}-${PV}.tar.gz \
7 file://0001-GNUmakefile-add-possibility-to-override-variables.patch \
8 file://nhttpd.conf \
9 file://volatiles \
10 file://tmpfiles.conf \
11 file://nostromo \
12"
13
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050014SRC_URI[md5sum] = "a054eb8e09560082793aaad676e33bd3"
15SRC_URI[sha256sum] = "1fad0a28d934835b582cedc98857e12e5adb991b14b87b52b39e6a501f4a9486"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17TARGET_CC_ARCH += "${LDFLAGS}"
18
19DEPENDS = "openssl groff-native base-passwd virtual/crypt"
20
21inherit update-rc.d
22
23INITSCRIPT_NAME = "nostromo"
24INITSCRIPT_PARAMS = "defaults 70"
25
26do_compile() {
27 oe_runmake
28}
29
30do_install() {
31 install -d ${D}/${sbindir}
32 install -m 0755 src/nhttpd/nhttpd ${D}/${sbindir}/nhttpd
33 install -m 0755 src/tools/crypt ${D}/${sbindir}/crypt
34 install -d ${D}/${mandir}/man8
35 install -m 0444 src/nhttpd/nhttpd.8 ${D}/${mandir}/man8/nhttpd.8
36 install -d ${D}${localstatedir}/nostromo/conf
37 install -d ${D}${localstatedir}/nostromo/htdocs/cgi-bin
38 install -d ${D}${localstatedir}/nostromo/icons
39 install -d ${D}${sysconfdir}/init.d
40 install -m 0644 conf/mimes ${D}${localstatedir}/nostromo/conf/mimes
41 install -m 0644 ${WORKDIR}/nhttpd.conf ${D}${sysconfdir}
42 install -m 0755 ${WORKDIR}/nostromo ${D}${sysconfdir}/init.d
43 install -D -m 0644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/nostromo
44 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
45 install -D -m 0644 ${WORKDIR}/tmpfiles.conf ${D}${sysconfdir}/tmpfiles.d/nostromo.conf
46 fi
47 install -m 0644 htdocs/index.html ${D}${localstatedir}/nostromo/htdocs/index.html
48 install -m 0644 htdocs/nostromo.gif ${D}${localstatedir}/nostromo/htdocs/nostromo.gif
49 install -m 0644 icons/dir.gif ${D}${localstatedir}/nostromo/icons/dir.gif
50 install -m 0644 icons/file.gif ${D}${localstatedir}/nostromo/icons/file.gif
51 chown -R www-data:www-data ${D}/${localstatedir}/nostromo
52}
53
54CONFFILES_${PN} += "/var/nostromo/conf/mimes ${sysconfdir}/nhttpd.conf"
55
56pkg_postinst_${PN} () {
57 if [ -z "$D" ]; then
58 if [ -e /sys/fs/cgroup/systemd ]; then
59 systemd-tmpfiles --create ${sysconfdir}/tmpfiles.d/nostromo.conf
60 elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
61 ${sysconfdir}/init.d/populate-volatile.sh update
62 fi
63 fi
64}