blob: 4c116ff99c0474ad4b5686adea50b922e0b601bb [file] [log] [blame]
Brad Bishop3077a7f2017-01-12 21:44:51 -05001SUMMARY = "OpenBMC - Applications"
Brad Bishop93fb5352015-09-09 03:59:20 +00002PR = "r1"
3
4inherit packagegroup
5inherit obmc-phosphor-utils
6inherit obmc-phosphor-license
7
Brad Bishop93fb5352015-09-09 03:59:20 +00008PROVIDES = "${PACKAGES}"
9PACKAGES = " \
Brad Bishopdb32a7c2017-03-01 16:16:06 -050010 ${PN}-bmc-state-mgmt \
11 ${PN}-chassis-state-mgmt \
Brad Bishopa2429372016-09-06 22:44:21 -040012 ${PN}-extras \
13 ${PN}-extrasdev \
Brad Bishop4824d4c2017-05-01 11:54:34 -040014 ${PN}-fan-control \
Brad Bishopdb32a7c2017-03-01 16:16:06 -050015 ${PN}-host-state-mgmt \
Brad Bishop4f12f722017-02-01 21:04:14 -050016 ${PN}-inventory \
17 ${PN}-leds \
18 ${PN}-sensors \
Gunnar Mills058788a2017-02-15 16:01:45 -060019 ${PN}-software \
Andrew Geisslerb1afecc2017-05-08 15:58:01 -050020 ${PN}-host-check-mgmt \
Jayanth Othayoth9be81b12017-05-08 09:25:05 -050021 ${PN}-debug-collector \
Brad Bishop93fb5352015-09-09 03:59:20 +000022 "
23
Brad Bishopdb32a7c2017-03-01 16:16:06 -050024SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
25RDEPENDS_${PN}-bmc-state-mgmt = " \
26 ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
27 "
28
29SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
30RDEPENDS_${PN}-chassis-state-mgmt = " \
31 ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
32 "
33
Andrew Geisslerb1afecc2017-05-08 15:58:01 -050034SUMMARY_${PN}-host-check-mgmt = "Host state check on bmc reset"
35RDEPENDS_${PN}-host-check-mgmt = " \
36 ${VIRTUAL-RUNTIME_obmc-host-check} \
37 "
38
Brad Bishopa2429372016-09-06 22:44:21 -040039SUMMARY_${PN}-extras = "Extra features"
40RDEPENDS_${PN}-extras = " \
Brad Bishop3077a7f2017-01-12 21:44:51 -050041 phosphor-rest \
Brad Bishop70436da2015-09-16 14:49:27 -040042 "
43
Brad Bishopa2429372016-09-06 22:44:21 -040044SUMMARY_${PN}-extrasdev = "Development features"
45RDEPENDS_${PN}-extrasdev = " \
Adriana Kobylaka3e925f2016-06-16 14:46:06 -050046 rest-dbus \
47 "
Brad Bishop4f12f722017-02-01 21:04:14 -050048
Brad Bishop4824d4c2017-05-01 11:54:34 -040049# Use the fan control package group for applications
50# implementing fan control or system fan policy only.
51# Applications that create inventory or sensors should
52# be added those respective package groups instead.
53SUMMARY_${PN}-fan-control = "Fan control"
54RDEPENDS_${PN}-fan-control = " \
55 "
56
Brad Bishopdb32a7c2017-03-01 16:16:06 -050057SUMMARY_${PN}-host-state-mgmt = "Host state management"
58RDEPENDS_${PN}-host-state-mgmt = " \
59 ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
Michael Tritzb3b58992017-03-31 12:04:32 -050060 ${VIRTUAL-RUNTIME_obmc-discover-system-state} \
Brad Bishopdb32a7c2017-03-01 16:16:06 -050061 "
62
Brad Bishop4f12f722017-02-01 21:04:14 -050063SUMMARY_${PN}-inventory = "Inventory applications"
64RDEPENDS_${PN}-inventory = " \
65 ${VIRTUAL-RUNTIME_obmc-inventory-manager} \
Matthew Barthacd9fe42017-02-24 13:14:43 -060066 ${VIRTUAL-RUNTIME_obmc-fan-presence} \
Brad Bishopd4c38482017-04-11 22:12:56 -040067 phosphor-chassis-cooling-type \
Brad Bishop4f12f722017-02-01 21:04:14 -050068 "
69
70SUMMARY_${PN}-leds = "LED applications"
71RDEPENDS_${PN}-leds = " \
Brad Bishopaf7d0602017-02-27 11:59:49 -050072 ${VIRTUAL-RUNTIME_obmc-leds-manager} \
73 ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
Brad Bishop4f12f722017-02-01 21:04:14 -050074 "
75
76SUMMARY_${PN}-sensors = "Sensor applications"
77RDEPENDS_${PN}-sensors = " \
78 ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
79 "
Gunnar Mills058788a2017-02-15 16:01:45 -060080
81SUMMARY_${PN}-software = "Software applications"
82RDEPENDS_${PN}-software = " \
83 ${VIRTUAL-RUNTIME_obmc-bmc-code-mgr} \
Deepak Kodihallib74ceea2017-04-13 23:23:42 -050084 ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
Gunnar Mills058788a2017-02-15 16:01:45 -060085 "
Jayanth Othayoth9be81b12017-05-08 09:25:05 -050086SUMMARY_${PN}-debug-collector = "BMC debug collector"
87RDEPENDS_${PN}-debug-collector = " \
88 ${VIRTUAL-RUNTIME_obmc-debug-collector} \