blob: 17c58e8e4c671dd1e34b0b417c0d2672708003cb [file] [log] [blame]
Patrick Williams9e206392017-01-19 21:20:46 -06001SUMMARY = "Phosphor State Management"
2DESCRIPTION = "Phosphor State Manager provides a set of system state \
3management daemons. It is suitable for use on a wide variety of OpenBMC \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager"
6PR = "r1"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10STATE_MGR_PACKAGES = " \
11 ${PN}-host \
12 ${PN}-chassis \
13"
14PACKAGES =+ "${STATE_MGR_PACKAGES}"
15DBUS_PACKAGES = "${STATE_MGR_PACKAGES}"
16
17# Set SYSTEMD_PACKAGES to empty because we do not want ${PN} and DBUS_PACKAGES
18# handles the rest.
19SYSTEMD_PACKAGES = ""
20
21inherit autotools pkgconfig
22inherit obmc-phosphor-dbus-service
23
24DEPENDS += "autoconf-archive-native"
25DEPENDS += "sdbusplus"
26DEPENDS += "phosphor-logging"
27
28RDEPENDS_${PN}-host += "libsystemd"
29RDEPENDS_${PN}-chassis += "libsystemd"
30
31PROVIDES += "virtual/obmc-host-state-mgmt"
32RPROVIDES_${PN}-host += "virtual-obmc-host-state-mgmt"
33FILES_${PN}-host = "${sbindir}/phosphor-host-state-manager"
34DBUS_SERVICE_${PN}-host += "xyz.openbmc_project.State.Host.service"
35
36PROVIDES += "virtual/obmc-chassis-state-mgmt"
37RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-state-mgmt"
38FILES_${PN}-chassis = "${sbindir}/phosphor-chassis-state-manager"
39DBUS_SERVICE_${PN}-chassis += "xyz.openbmc_project.State.Chassis.service"
40
41SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
42SRCREV = "6e0b50936735faac96db2f20fe84ffd0733750a9"
43
44S = "${WORKDIR}/git"